February product update roundup

A quick roundup of recent improvements, polish, and bug fixes.

  • Add new rows - Adding a new row to your pipelines is now made easier with "+" buttons next to each stage header.

Image 2020-02-21 at 10.52.18 AM.png

  • Change Stage in pipeline view - We gave the Stage column a little makeover and you can now use the dropdown menu to change the stage of a box.

Image 2020-02-21 at 11.23.56 AM.png

  • Shortcuts to add new fields to your pipeline - You can now add new fields (columns) to your pipelines from several locations, including the Streak sidebar and the box view.

Image 2020-02-21 at 11.44.32 AM.png Image 2020-02-21 at 11.43.49 AM.png

  • Custom pipeline templates - Custom pipeline templates are back by popular demand so you can build your pipeline from the ground up.

Bug Fixes 🐞

  • Unified Replies - In the early days of Unified Reply, messages sent using the new feature were ending up in drafts. It's now working as intended - thanks for bearing with us while we ironed out the kinks.

  • Email filters - If you deleted a box with an email filter, that filter couldn't be used in other boxes. Stay tuned for some big updates to email filter behavior in coming weeks 👀

  • Files in box timelines - We were having issues displaying Drive files that should have appeared in box timelines. This issue is now "filed" under "resolved" 📂.

  • Viewing details from compose window - When composing email drafts that have been added to a box, clicking "show details" opened a blank sidebar. Not exactly what we had in mind 🤔.

  • Quick Add duplicates - Adding suggested people and companies from the sidebar of the pipeline view appeared to create a duplicate box in your pipeline 👯.

  • Box label behavior while viewing email threads - In some scenarios, clicking on the label didn't open the box information in the sidebar. Now you'll see the relevant information when clicking on a box label at the top of an email thread.

Untitled.png

  • Preview pane compatibility - The Streak sidebar wasn't appearing consistently for customers with preview pane enabled.